Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 17, 2025 - 22:30 CEST
Scheduled
This notification is for upcoming scheduled maintenance to our services. Maintenance is optimized for non-business hours. During this maintenance, your BookingStudio Installation may see a drop in connectivity for a short time.
Posted Sep 17, 2025 - 17:49 CEST
This scheduled maintenance affected: Web Application.